Basic OSPF Configuration

ip routing

router ospf 1
router-id 172.16.1.1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0 255 area 1
passive-interface default
no passive-interface vlan 10
no passive-interface vlan 20
default-information originate always

Can also use ospf on interfaces:
router ospf 1

int vlan 10
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0

int vlan 20
ip address 10.1.2.1 255.255.255.0
ip ospf 1 area 1

clear ip ospf process

Adjusting metrics
int vlan 20
ip ospf cost 5

********************************

ipv6 unicast-routing
ipv6 router ospf 1
(All networks per interface)
copy vlans to notepad
edit to add the following to each vlan
int vlan 10
ip ospf 1 area 0

Be the first to comment

Leave a Reply

Your email address will not be published.


*